System Requirements

Minimum System Requirements

Blue Moon Software is a web-based application used in creating, printing, and electronic signing of official association documents. We’ve worked to create interfaces, features and resources to allow compatibility with most web browsers.

With all technology, change is guaranteed. As additional enhancements and new features are developed, the system requirements needed to support them will change. It is important to stay up-to-date with the most recent release of any supported system.

Compatible Browsers:

Compatible PDF Generation:

Adobe Acrobat Reader

Note:
  • In some cases, browser add-ons, extensions or plugins can interfere with the functionality of our application. If you see unexpected behavior, you may want to disable these items or try another browser to see if the behavior improves.
  • Pop-ups and JavaScript should be enabled in your browser to view alerts, errors and preview screens.
  • Microsoft Edge is not supported at this time. Microsoft Edge displays the document as an image. This image must then be saved as a PDF file and then re-opened before printing. Updating your default PDF settings to Adobe Acrobat Reader may improve compatibility.
  • Microsoft Internet Explorer (IE) versions 9, 8 and 7 are not supported.  
  • Windows Vista and Windows XP operating systems are not supported.